]> Pileus Git - ~andy/sunrise/blob - app-misc/bsc/bsc-4.0.06_beta.ebuild
app-misc/bsc: Fix homepage link
[~andy/sunrise] / app-misc / bsc / bsc-4.0.06_beta.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 inherit eutils qt4 versionator
7
8 MY_PV="$(replace_version_separator 3 '.')"
9 DESCRIPTION="BSCommander is a Qt based file manager"
10 HOMEPAGE="http://www.beesoft.org/index.php?id=bsc"
11 SRC_URI="http://www.beesoft.org/download/${PN}_${MY_PV}_src.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 IUSE=""
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND=">=x11-libs/qt-4.3.2:4
19         x11-libs/libX11
20         x11-libs/libXext"
21 RDEPEND="${DEPEND}"
22
23 S="${WORKDIR}/${PN}"
24
25 src_unpack() {
26         unpack ${A}
27         cd "${S}"
28         sed -i -e "/^CXXFLAGS.*/s:-pipe -O4:${CXXFLAGS}:" \
29                 Makefile || die "sed failed on Makefile"
30         sed -i -e "/^QMAKE_CXXFLAGS_RELEASE.*/s:-O4:${CXXFLAGS}:" \
31                 ${PN}.pro || die "sed failed on ${PN}.pro"
32 }
33
34 src_compile() {
35         eqmake4 bsc.pro
36         emake || die "make failed"
37 }
38
39 src_install() {
40         dobin ${PN}
41
42         insinto /usr/share/${PN}
43         doins help.en.html
44
45         newicon BeesoftCommander.png ${PN}.png
46         make_desktop_entry ${PN} BSCommander ${PN} "FileManager;Utility;Qt"
47 }