]> Pileus Git - ~andy/sunrise/blob - app-misc/bsc/bsc-2.27.ebuild
3771ae07b2bd17dbbd29e5e21f9145fe3e289b4f
[~andy/sunrise] / app-misc / bsc / bsc-2.27.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils qt3
6
7 DESCRIPTION="BSCommander is a Qt based file manager"
8 HOMEPAGE="http://www.beesoft.org/bsc.html"
9 SRC_URI="http://www.beesoft.org/download/${PN}_${PV}_src.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 IUSE=""
14 KEYWORDS="~x86"
15
16 DEPEND="$(qt_min_version 3.3)
17         x11-libs/libX11
18         x11-libs/libXext"
19 RDEPEND="${DEPEND}"
20
21 S="${WORKDIR}/${PN}"
22
23 src_compile() {
24         ${QTDIR}/bin/qmake -o Makefile bsc.pro \
25                 QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
26                 QMAKE_RPATH= \
27                 || die "qmake failed"
28
29         emake || die "make failed"
30 }
31
32 src_install() {
33         dobin ${PN}
34
35         insinto /usr/share/${PN}/images
36         doins images/*
37
38         insinto /usr/share/${PN}/lang
39         doins *.qm
40
41         newicon BeesoftCommander.png ${PN}.png
42         make_desktop_entry ${PN} BSCommander ${PN}.png "FileManager;Utility;Qt"
43
44         dodoc ChangeLog.txt
45 }