]> Pileus Git - ~andy/sunrise/blob - app-misc/bbgallery/bbgallery-1.2.0-r2.ebuild
net-misc/freego: Fix qt deps
[~andy/sunrise] / app-misc / bbgallery / bbgallery-1.2.0-r2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Webpage image gallery creation perl script"
8 HOMEPAGE="http://bbgallery.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
10
11 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="~x86"
14 IUSE="doc"
15
16 RDEPEND="dev-lang/perl
17         media-gfx/imagemagick
18         dev-perl/URI
19         dev-perl/libwww-perl
20         dev-perl/HTML-Template
21         dev-perl/HTML-Parser"
22 DEPEND=""
23
24 src_unpack() {
25         unpack ${A}
26         cd "${S}"
27         epatch "${FILESDIR}/${P}-path-fix.patch"
28 }
29
30 src_install() {
31         local inspath="/usr/share/${PN}"
32
33         dobin ${PN} || die "dobin failed"
34         newbin Contrib/JPG2jpg.pl JPG2jpg || die "newbin failed"
35
36         exeinto "${inspath}"
37         doexe gimp_scale.pl || die "doexe failed"
38
39         insinto "${inspath}"
40         doins -r template/ || die "doins failed"
41         dosym "${inspath}"/template/monochrome "${inspath}"/template/default \
42                 || die "dosym failed"
43
44         dodoc CHANGELOG CREDITS README || die "dodoc failed"
45         if use doc; then
46                 dohtml -r doc/ || die "dohtml failed"
47         fi
48 }