]> Pileus Git - ~andy/sunrise/blob - app-misc/autokey-gtk/autokey-gtk-0.60.7a.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / app-misc / autokey-gtk / autokey-gtk-0.60.7a.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 DESCRIPTION="A programm for automating tasks in Linux"
8 HOMEPAGE="http://autokey.sourceforge.net/"
9 SRC_URI="http://autokey.googlecode.com/files/${PN}_${PV}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND=">=dev-python/python-xlib-0.14
17         dev-python/notify-python
18         dev-python/pygtk"
19
20 RDEPEND="${DEPEND}"
21
22 S="${WORKDIR}/build"
23
24 src_install(){
25         distutils_src_install
26         newinitd "${S}"/debian/autokey-gtk.init autokey || die
27 }
28
29 pkg_postinst () {
30         einfo "You should now run /etc/init.d/dbus reload"
31         einfo " You may now start the ${PN} deamon with /etc/init.d/autokey start."
32         einfo " If you want to start the deamon every time Gentoo starts,"
33         einfo " you should run rc-update add autokey default"
34 }