]> Pileus Git - ~andy/sunrise/blob - app-laptop/toshset/toshset-1.72.ebuild
f2e2f0d7fd5f7bdab4db1449ec506961f2e1d6dd
[~andy/sunrise] / app-laptop / toshset / toshset-1.72.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Utility to modify HCI/SCI controls on Toshiba Laptops"
6 HOMEPAGE="http://www.schwieters.org/toshset/"
7 SRC_URI="mirror://debian/pool/main/t/${PN}/${PN}_${PV}.orig.tar.gz"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND=""
15 RDEPEND=""
16
17 src_unpack() {
18         unpack ${A}
19         sed -i 's/CFLAGS = -march=i486 \(-Wall @OS_CFLAGS@ @DEBUGFLAGS@\)/CFLAGS := \1 ${CFLAGS}/' "${S}/Makefile.in" || die "sed failed"
20 }
21
22 src_install() {
23         emake DESTDIR="${D}" install || die "emake install failed"
24         dodoc README
25 }