]> Pileus Git - ~andy/sunrise/blob - app-editors/yzis/yzis-1.0_alpha1.ebuild
f99b41a4b73bb19ca1613cb504244de9744f6c48
[~andy/sunrise] / app-editors / yzis / yzis-1.0_alpha1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit cmake-utils
8
9 MY_P=${P/_/-}
10
11 DESCRIPTION="Vi-like editor inspired by vim"
12 HOMEPAGE="http://www.yzis.org/"
13 SRC_URI="http://labs.freehackers.org/attachments/download/45/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-2 LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~x86"
18 IUSE=""
19
20 DEPEND=">=dev-lang/lua-5.1
21         sys-libs/ncurses
22         x11-libs/qt-gui:4"
23 RDEPEND="${DEPEND}"
24
25 DOCS="ChangeLog README"
26
27 src_configure() {
28         mycmakeargs="${mycmakeargs}  -DENABLE_TESTS=OFF \
29                 -DENABLE_LIBYZISRUNNER=OFF \
30                 -DDCMAKE_BUILD_TYPE=Release "
31         cmake-utils_src_configure
32 }