]> Pileus Git - ~andy/sunrise/blob - app-editors/x2/x2-1.1.0.ebuild
dev-db/cppdb: Adding ~amd64 keyword
[~andy/sunrise] / app-editors / x2 / x2-1.1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="A micro-ide/text editor written in C/GTK+"
10 HOMEPAGE="http://gnomefiles.org/content/show.php/X2?content=145463"
11 SRC_URI="http://gnomefiles.org/CONTENT/content-files/145463-${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 RDEPEND="x11-libs/gtksourceview:2.0
19         x11-libs/vte:0"
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig"
22
23 src_prepare(){
24         epatch "${FILESDIR}/${P}-desktop.patch"
25         epatch "${FILESDIR}/${P}-Makefile.patch"
26         tc-export CC
27 }