]> Pileus Git - ~andy/sunrise/blob - app-editors/scribes/scribes-0.4.ebuild
net-misc/wolman: Fix qt deps
[~andy/sunrise] / app-editors / scribes / scribes-0.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 PYTHON_DEPEND="2:2.6"
8 GCONF_DEBUG=no
9
10 build=954
11
12 inherit autotools eutils gnome2 python
13
14 MY_P="${P}-dev-build${build}"
15 DESCRIPTION="a text editor that is simple, slim and sleek, yet powerful"
16 HOMEPAGE="http://scribes.sourceforge.net"
17 SRC_URI="http://launchpad.net/scribes/${PV}/scribes-milestone1/+download/${MY_P}.tar.bz2"
18
19 LICENSE="GPL-2"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="doc"
23
24 RDEPEND="gnome-base/gconf
25         doc? ( gnome-extra/yelp )
26         dev-libs/dbus-glib
27         dev-python/dbus-python
28         dev-python/pygtk
29         dev-python/gtkspell-python
30         dev-python/pygtksourceview
31         dev-python/pyxdg"
32 DEPEND="app-text/gnome-doc-utils
33         virtual/pkgconfig
34         dev-util/intltool
35         sys-devel/gettext"
36
37 S=${WORKDIR}/${MY_P}
38
39 DOCS="AUTHORS ChangeLog CONTRIBUTORS NEWS README TODO TRANSLATORS"
40
41 pkg_setup() {
42         python_set_active_version 2
43         G2CONF="--disable-scrollkeeper"
44 }
45
46 src_prepare() {
47         epatch "${FILESDIR}"/${PN}-sandbox.patch
48         # keep make from byte-compiling python modules itself
49         epatch "${FILESDIR}"/${PN}-byte-compiling-plugins.patch
50         eautoreconf
51
52         # make py-compile useless (but true)
53         echo '#!/bin/sh' > py-compile || die "Could not kill py-compile"
54
55         python_convert_shebangs -r 2 .
56
57         gnome2_src_prepare
58 }
59
60 src_install() {
61         gnome2_src_install
62         python_clean_installation_image
63 }
64
65 pkg_postinst() {
66         gnome2_pkg_postinst
67         python_mod_optimize SCRIBES
68 }
69
70 pkg_postrm() {
71         gnome2_pkg_postrm
72         python_mod_cleanup SCRIBES
73 }