]> Pileus Git - ~andy/sunrise/blob - app-editors/mined/mined-2000.16.ebuild
sci-geosciences/aweather: Version bump for aweather-0.8.1
[~andy/sunrise] / app-editors / mined / mined-2000.16.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit base toolchain-funcs
8
9 DESCRIPTION="Text editor with extensive Unicode and CJK support"
10 HOMEPAGE="http://mined.sourceforge.net/"
11 SRC_URI="http://towo.net/mined/download/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 DOCS=( README CHANGES )
19
20 src_prepare() {
21         default
22
23         # Disable stripping and supply the correct compiler
24         # we can't just pass CC as upstream uses it as a keyword-var
25         sed -i -e '/strip/d' -e "s/\$(CC)/$(tc-getCC)/" src/mkinclud.mak || die
26 }
27
28 src_compile() {
29         emake OPT="${CFLAGS}" || die
30 }