]> Pileus Git - ~andy/sunrise/blob - app-editors/hexer/hexer-0.1.7.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / app-editors / hexer / hexer-0.1.7.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="Hex editor with vi/ex-style user interface"
10 HOMEPAGE="http://devel.ringlet.net/editors/hexer/"
11 SRC_URI="http://devel.ringlet.net/editors/${PN}/${P}.tar.gz"
12
13 LICENSE="hexer"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="sys-libs/ncurses"
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P}-qa.patch
23 }
24
25 src_compile() {
26         tc-export CC
27         default
28 }
29
30 src_install() {
31         dobin ${PN} bin2c
32         doman ${PN}.1
33         dodoc CHANGES README
34 }