]> Pileus Git - ~andy/sunrise/blob - app-dicts/words-bin/words-bin-1.97.ebuild
777fc262cbff3f1190b94d87e2e38135eef41d2b
[~andy/sunrise] / app-dicts / words-bin / words-bin-1.97.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 MY_P="words-${PV}"
8
9 DESCRIPTION="Latin-English dictionary."
10 HOMEPAGE="http://users.erols.com/whitaker/words.htm"
11 SRC_URI="ftp://petrus.thomasaquinas.edu/pub/linux/words/$MY_P-linux.tar.gz"
12
13 SLOT="0"
14 LICENSE="words"
15 KEYWORDS="~x86"
16
17 IUSE=""
18 DEPEND=""
19 RDEPEND=""
20
21 S=$WORKDIR/$MY_P
22
23 src_unpack(){
24         unpack ${A}
25         cd "${S}"
26         epatch "${FILESDIR}"/words_dir.patch
27 }
28
29 src_install() {
30         insinto /opt/$MY_P
31         dodir /usr/bin
32         dodoc wordsdoc*
33         rm wordsdoc*
34         doins *
35         dosym "$D"/opt/$MY_P/latin /usr/bin/latin
36         fperms 755 /opt/$MY_P/{latin,words}
37 }
38
39 pkg_postinst() {
40         einfo "Dictionary is launched through 'latin' command"
41 }