]> Pileus Git - ~andy/sunrise/blob - app-dicts/ktranslator/ktranslator-0.4.ebuild
app-dicts/ktranslator: adjusted DESCRIPTION
[~andy/sunrise] / app-dicts / ktranslator / ktranslator-0.4.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit kde
6
7 DESCRIPTION="A translation program to KDE"
8 HOMEPAGE="http://ktranslator.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="festival lowmem ocr"
15 #Flags to choose which plugins should be compiled
16 #IUSE="${IUSE} babylon dictd plaintext sdict stardict"
17 RDEPEND="ocr? ( app-text/gocr )
18         festival? ( app-accessibility/festival )"
19
20 need-kde 3.3
21
22 src_compile() {
23         myconf="$(use_enable !lowmem opts)"
24
25         #Handling of flags to choose plugins which should be compiled
26         #myconf=${myconf} --with-plugins=$(usev babylon),$(usev dictd),$(usev plaintext),$(usev sdict),$(usev stardict)"
27
28         kde_src_compile
29 }