]> Pileus Git - ~andy/sunrise/blob - app-crypt/yapet/yapet-0.8_pre2.ebuild
app-misc/qbrew: Fix qt deps, EAPI bump
[~andy/sunrise] / app-crypt / yapet / yapet-0.8_pre2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit base versionator
8
9 MY_P=${PN}-$(delete_version_separator 2)
10
11 DESCRIPTION="A curses (text) based password encryption tool"
12 HOMEPAGE="http://www.guengel.ch/myapps/yapet/"
13 SRC_URI="http://www.guengel.ch/myapps/yapet/downloads/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="csv nls pwgen"
19
20 RDEPEND="nls? ( virtual/libintl )
21         >=sys-libs/ncurses-5.6
22         >=dev-libs/openssl-0.9.7"
23 DEPEND="${RDEPEND}"
24
25 S=${WORKDIR}/${MY_P}
26
27 src_configure() {
28         econf --enable-terminal-title \
29                 --disable-source-doc \
30                 --disable-build-doc \
31                 $(use_enable csv csv2yapet) \
32                 $(use_enable nls) \
33                 $(use_enable pwgen)
34 }