]> Pileus Git - ~andy/sunrise/blob - app-crypt/mypasswordsafe/mypasswordsafe-20061216.ebuild
app-crypt/mypasswordsafe: epatch dies itself with much more useful error messages
[~andy/sunrise] / app-crypt / mypasswordsafe / mypasswordsafe-20061216.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils qt3 toolchain-funcs
6
7 MY_P=${P/mypasswords/MyPasswordS}
8
9 DESCRIPTION="A password manager compatible with Password Safe."
10 HOMEPAGE="http://www.semanticgap.com/myps/"
11 SRC_URI="http://www.semanticgap.com/myps/release/${MY_P}.src.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND="$(qt_min_version 3.3)"
19 RDEPEND="${DEPEND}"
20
21 S=${WORKDIR}/${MY_P}
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26         epatch "${FILESDIR}/${PF}-qtdir.patch"
27 }
28
29 src_compile() {
30         emake CXX=$(tc-getCXX) PREFIX="/usr" all || die "emake failed"
31 }
32
33 src_install() {
34         emake PREFIX="${D}/usr" install || die "emake install failed"
35 }