]> Pileus Git - ~andy/sunrise/blob - app-crypt/mypasswordsafe/mypasswordsafe-20061216.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / app-crypt / mypasswordsafe / mypasswordsafe-20061216.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 inherit eutils qt3 toolchain-funcs
7
8 MY_P=${P/mypasswords/MyPasswordS}
9
10 DESCRIPTION="A password manager compatible with Password Safe."
11 HOMEPAGE="http://www.semanticgap.com/myps/"
12 SRC_URI="http://www.semanticgap.com/myps/release/${MY_P}.src.tgz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~x86"
17 IUSE=""
18
19 DEPEND=">=x11-libs/qt-3.3:3"
20 RDEPEND="${DEPEND}"
21
22 S="${WORKDIR}/${MY_P}"
23
24 src_unpack() {
25         unpack ${A}
26         cd "${S}"
27         epatch "${FILESDIR}/${PF}-qtdir.patch"
28 }
29
30 src_compile() {
31         emake CXX=$(tc-getCXX) PREFIX="/usr" all || die "emake failed"
32 }
33
34 src_install() {
35         emake PREFIX="${D}/usr" install || die "emake install failed"
36 }