]> Pileus Git - ~andy/sunrise/blob - app-crypt/miracl/miracl-5.4.1.ebuild
games-strategy/freesynd: in main tree
[~andy/sunrise] / app-crypt / miracl / miracl-5.4.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils multilib toolchain-funcs
8
9 DESCRIPTION="Big number cryptography library"
10 HOMEPAGE="http://www.shamus.ie"
11 SRC_URI="http://chaox.net/~jens/${P}.tar.bz2"
12
13 LICENSE="free-noncomm"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 src_prepare() {
19         epatch "${FILESDIR}"/${PN}-fix-buildsystem.patch
20         epatch "${FILESDIR}"/${PN}-noexecstack.patch
21 }
22
23 src_compile() {
24         chmod +x ./linux || die
25         CC="$(tc-getCC)" CXX="$(tc-getCXX)" AS="$(tc-getAS)" AR="$(tc-getAR)" ./linux || die
26 }
27
28 src_install() {
29         dolib.a lib${PN}.a || die
30         dolib.so lib${PN}.so.0.0.0 || die
31         dosym lib${PN}.so.0.0.0 /usr/$(get_libdir)/lib${PN}.so || die
32         insinto /usr/include/${PN}
33         doins ${PN}.h mirdef.h || die
34         dodoc *.txt || die
35 }