]> Pileus Git - ~andy/sunrise/blob - app-cdr/acetoneiso2/acetoneiso2-2.0.1.ebuild
bd7f5be417b4f4b2f05e2d4cc79333f2b9e6ed2f
[~andy/sunrise] / app-cdr / acetoneiso2 / acetoneiso2-2.0.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=1
6 inherit qt4
7
8 DESCRIPTION="Graphical tool to do a lot things with image files like extracting, mounting, encrypting."
9 HOMEPAGE="http://sourceforge.net/projects/acetoneiso2/"
10 SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}-source.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="7zip cdr crypt"
16
17 DEPEND="x11-libs/qt:4
18         || ( kde-base/konqueror gnome-base/nautilus kde-base/kdebase )
19         sys-fs/fuse
20         sys-fs/fuseiso"
21
22 RDEPEND="${DEPEND}
23         7zip? ( app-arch/p7zip )
24         cdr? ( virtual/cdrtools app-cdr/cdrdao )
25         crypt? ( >=app-crypt/gnupg-2 app-crypt/pinentry )"
26
27 S="${WORKDIR}"/${PN}/src/
28
29 src_compile() {
30         eqmake4 || die "qmake failed"
31         emake || die "emake failed"
32 }
33
34 src_install() {
35         INSTALL_ROOT="${D}" einstall || die "install failed"
36 }