]> Pileus Git - ~andy/sunrise/blob - app-cdr/acetoneiso2/acetoneiso2-2.0.0.ebuild
app-cdr/acetoneiso2: Added sys-fs/fuseiso to DEPEND. Thanks to realmatrix.
[~andy/sunrise] / app-cdr / acetoneiso2 / acetoneiso2-2.0.0.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=1
6
7 inherit qt4
8
9 DESCRIPTION="Graphical tool to do a lot things with image files like extracting, mounting, encrypting."
10 HOMEPAGE="http://sourceforge.net/projects/acetoneiso2/"
11 SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}-source.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="cdr crypt"
17
18 DEPEND="
19         x11-libs/qt:4
20         cdr? (  app-cdr/cdrtools
21                 app-cdr/cdrdao )
22         app-arch/p7zip
23         || ( kde-base/konqueror gnome-base/nautilus kde-base/kdebase )
24         crypt? ( >=app-crypt/gnupg-2 )
25         sys-fs/fuse
26         sys-fs/fuseiso"
27
28 RDEPEND=${DEPEND}
29
30 S="${WORKDIR}"/${PN}/src/
31
32 src_compile() {
33         eqmake4 || die "qmake failed"
34         emake || die "emake failed"
35 }
36
37 src_install() {
38         INSTALL_ROOT="${D}" einstall || die "install failed"
39 }