]> Pileus Git - ~andy/sunrise/blob - app-cdr/acetoneiso/acetoneiso-2.0.3.ebuild
app-cdr/acetoneiso: Removed eutils inherit.
[~andy/sunrise] / app-cdr / acetoneiso / acetoneiso-2.0.3.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit qt4
8
9 MY_P="${PN}_${PV/_rc/RC}"
10
11 DESCRIPTION="Graphical tool to do a lot things with image files like extracting, mounting, encrypting."
12 HOMEPAGE="http://www.acetoneteam.org/"
13 SRC_URI="mirror://sourceforge/${PN}2/${MY_P}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc"
19
20 # remove the blocker after some time
21 DEPEND="x11-libs/qt-gui
22         x11-libs/qt-webkit
23         !app-cdr/acetoneiso2"
24 RDEPEND="${DEPEND}"
25
26 S="${WORKDIR}/${MY_P}/src/"
27
28 src_prepare() {
29         # unrar is called unrar-nonfree there
30         sed -i -e 's:unrar-nonfree:unrar:g' sources/compress.h locale/*.ts \
31                 || die "sed failed"
32 }
33
34 src_configure() {
35         eqmake4
36 }
37
38 src_install() {
39         emake INSTALL_ROOT="${D}" install || die "emake install failed"
40
41         dodoc ../{AUTHORS,CHANGELOG,FEATURES,README} || die "dodoc failed"
42
43         if use doc; then
44                 dohtml -r manual/* || die "dohtml failed"
45         fi
46 }
47
48 pkg_postinst() {
49         elog
50         elog "The following packages will give ${PN} extended functionality:"
51
52         elog "Filemanager:"
53         elog "\tkde-base/dolphin"
54         elog "\tkde-base/konqueror"
55         elog "\tgnome-base/nautilus"
56
57         elog "Video player:"
58         elog "\tmedia-video/mplayer"
59         elog "\tmedia-video/smplayer"
60         elog "\tmedia-video/kaffeine"
61         elog "\tmedia-video/vlc"
62
63         elog "Image mounting:"
64         elog "\tsys-fs/fuse"
65         elog "\tsys-fs/fuseiso"
66
67         elog "Image encryption:"
68         elog "\t>=app-crypt/gnupg-2"
69
70         elog "Image compression:"
71         elog "\tapp-arch/p7zip"
72         elog "\tapp-arch/unrar"
73
74         elog "Encoding:"
75         elog "\tmedia-video/ffmpeg"
76         elog "\tmedia-sound/lame"
77         elog "\tmedia-video/mplayer (mencoder)"
78
79         elog "Device info:"
80         elog "\tsys-apps/hal"
81
82         elog "CD/DVD burning, image creation etc.:"
83         elog "\tapp-cdr/cdrkit"
84         elog "\tapp-cdr/cdrdao"
85         elog "\tmedia-sound/cdparanoia"
86
87         elog "Additional tools which are not in the portage tree:"
88         elog "\tgeteltorito - http://www.uni-koblenz.de/~krienke/ftp/noarch/geteltorito/"
89         elog "\tciso - http://ciso.tenshu.fr/"
90
91         elog
92         elog "for further informations see README"
93         elog
94 }