]> Pileus Git - ~andy/sunrise/blob - app-backup/rdup/rdup-1.1.14.ebuild
dev-db/dabo: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / app-backup / rdup / rdup-1.1.14.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils
8
9 DESCRIPTION="Generate a file list suitable for full or incremental backups"
10 HOMEPAGE="http://www.miek.nl/projects/rdup"
11 SRC_URI="http://www.miek.nl/projects/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug test"
17
18 RDEPEND="
19         app-arch/libarchive
20         dev-libs/glib:2
21         dev-libs/libpcre
22         dev-libs/nettle"
23 DEPEND="${RDEPEND}
24         test? ( dev-util/dejagnu )"
25
26 src_prepare() {
27         default_src_prepare
28         # see https://github.com/miekg/rdup/pull/4
29         epatch "${FILESDIR}/${P}-fix-strip.patch"
30 }
31
32 src_configure() {
33         econf $(use_enable debug)
34 }
35
36 src_test() {
37         if use debug; then
38                 ewarn "Test phase skipped, as it is known to fail with USE=\"debug\"."
39         else
40                 default_src_test
41         fi
42 }