]> Pileus Git - ~andy/sunrise/blob - app-backup/rdup/rdup-0.9.0.ebuild
0d0f264e870f6a42c2c216e07714c009b2753c29
[~andy/sunrise] / app-backup / rdup / rdup-0.9.0.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit autotools eutils
6
7 DESCRIPTION="rdup is a utility inspired by rsync and the plan9 way of doing backups."
8 HOMEPAGE="http://www.miek.nl/projects/rdup"
9 SRC_URI="http://www.miek.nl/projects/${PN}/${P}.tar.bz2"
10 LICENSE="GPL-3"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="path-encryption"
15
16 DEPEND="app-arch/libarchive
17         dev-libs/glib
18         dev-libs/libpcre
19         path-encryption? ( dev-libs/nettle )"
20 RDEPEND=${DEPEND}
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         epatch "${FILESDIR}/${P}-configure-ac.patch"
26
27         eautoreconf
28 }
29
30 src_compile() {
31         econf $(use_with path-encryption nettle )
32
33         emake || die "emake failed"
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" install || die "emake install failed"
38
39         dosym ../lib/rdup/rdup-simple.sh /usr/bin/rdup-simple || die "dosym failed"
40
41         dodoc AUTHORS ChangeLog DESIGN README || die "dodoc failed"
42 }