]> Pileus Git - ~andy/sunrise/blob - app-arch/zpaq-extras/zpaq-extras-0_p20091101.ebuild
app-arch/zpaq-extras: Additional ebuild to bug #278021.
[~andy/sunrise] / app-arch / zpaq-extras / zpaq-extras-0_p20091101.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="Extra configurations for zpaq"
8 HOMEPAGE="http://mattmahoney.net/dc/#zpaq"
9 SRC_URI="http://mattmahoney.net/dc/bwt_j3.zip
10         http://mattmahoney.net/dc/bwt_slowmode1.zip
11         http://mattmahoney.net/dc/bmp_j4.zip
12         http://mattmahoney.net/dc/exe_j1.zip
13         http://mattmahoney.net/dc/jpg_test2.zip"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE=""
19
20 DEPEND="app-arch/unzip"
21 RDEPEND=""
22
23 src_compile() {
24         local _prog
25
26         mkdir bin
27         for _prog in bwtpre bwt_ jpeg_jo exe_jo; do
28                 "$(tc-getCXX)" ${CXXFLAGS} ${_prog}.cpp -o bin/${_prog} \
29                         || die "compiling ${_prog} failed"
30         done
31
32         sed \
33                 -e 's:^pcomp zpaq r:pcomp /usr/bin/zpaq r/usr/share/zpaq/:' \
34                 -e 's:^pcomp \([^/]\):pcomp /usr/libexec/zpaq/\1:' \
35                 -i *.cfg || die 'sed failed'
36 }
37
38 src_install() {
39         exeinto /usr/libexec/zpaq
40         doexe bin/* || die 'dobin failed'
41
42         insinto /usr/share/zpaq
43         doins *.cfg || die 'doins failed'
44 }