]> Pileus Git - ~andy/sunrise/blob - app-arch/parano/parano-0.3.3.ebuild
Revert to revision 1964
[~andy/sunrise] / app-arch / parano / parano-0.3.3.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WANT_AUTOCONF="latest"
6 WANT_AUTOMAKE="latest"
7 inherit gnome2 autotools
8
9 DESCRIPTION="GNOME program to create, edit and verify hashfiles"
10 HOMEPAGE="http://parano.berlios.de/"
11 SRC_URI="http://download.berlios.de/parano/${P}.tar.gz
12         http://download2.berlios.de/parano/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~ppc ~x86"
17 IUSE="doc"
18
19 DEPEND=">=dev-python/pygtk-2.0
20         dev-python/gnome-python"
21 RDEPEND="${DEPEND}"
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26
27         # Many fixes, thanks to dragonheart
28         mv src/parano.py src/parano.in
29         epatch "${FILESDIR}/${P}-autoconf.patch"
30         eautoreconf
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install || die "emake install failed"
35         dodoc AUTHORS ChangeLog README NEWS TODO
36 }