]> Pileus Git - ~andy/sunrise/blob - app-arch/parano/parano-0.3.3.ebuild
app-arch/parano: autoconf fixes, thanks to dragonheart
[~andy/sunrise] / app-arch / parano / parano-0.3.3.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit gnome2 autotools
6
7 DESCRIPTION="GNOME program to create, edit and verify hashfiles"
8 HOMEPAGE="http://parano.berlios.de"
9 SRC_URI="http://download.berlios.de/parano/${P}.tar.gz
10         http://download2.berlios.de/parano/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE="doc"
16
17 RDEPEND=">=dev-python/pygtk-2.0
18         dev-python/gnome-python"
19 DEPEND="${RDEPEND}"
20
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         
26         # Many fixes, thanks to dragonheart
27         mv src/parano.py src/parano.in
28         epatch "${FILESDIR}/${P}-autoconf.patch"
29         eautoreconf
30 }
31
32 src_install() {
33         emake install DESTDIR="${D}" || die "emake install failed"
34         dodoc AUTHORS ChangeLog README NEWS TODO
35 }