]> Pileus Git - ~andy/sunrise/blob - app-arch/paq8l/paq8l-20070308.ebuild
app-arch/paq8l: Whitespace and fix of
[~andy/sunrise] / app-arch / paq8l / paq8l-20070308.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="Open source file compressor and archiver"
8 HOMEPAGE="http://www.cs.fit.edu/~mmahoney/compression"
9 SRC_URI="http://www.cs.fit.edu/~mmahoney/compression/${PN}.zip"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~x86"
14
15 IUSE=""
16
17 DEPEND="app-arch/unzip"
18 RDEPEND=""
19
20 S=${WORKDIR}/${PN}
21
22 src_compile() {
23         $( tc-getCXX ) ${CXXFLAGS} -DNOASM -DUNIX ${PN}.cpp -o ${PN} || die "compile failed"
24 }
25
26 src_install() {
27         dobin ${PN} || die "dobin failed"
28         dodoc readme.txt || die "dodoc failed"
29 }