]> Pileus Git - ~andy/sunrise/blob - app-antivirus/panda/panda-9.00.00.ebuild
app-antivirus/panda - cosmetics
[~andy/sunrise] / app-antivirus / panda / panda-9.00.00.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 S="${WORKDIR}"
6
7 DESCRIPTION="Panda Antivirus for Linux"
8 HOMEPAGE="http://www.pandasoftware.com/download/linux/linux.asp"
9 SRC_URI="http://shareware.pandasoftware.com/shareware/pavcl_linux.tgz"
10
11 SLOT="0"
12 LICENSE="Panda-Freeware"
13 KEYWORDS="-* ~x86"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND=""
18 PROVIDE="virtual/antivirus"
19
20 RESTRICT="mirror strip"
21 QA_TEXTRELS_x86="opt/pavcl/usr/lib/libPsk*.so.*"
22
23 src_install() {
24         cd "${S}"
25         cp -r . "${D}"
26
27         dodir /etc/env.d
28         echo "PATH=\"/opt/pavcl/usr/bin\"" >> "${D}"/etc/env.d/90panda
29         echo "MANPATH=\"/opt/pavcl/usr/man\"" >> "${D}"/etc/env.d/90panda
30 }
31
32 pkg_postinst() {
33         einfo "See \"man pavcl\" for usage instructions."
34         einfo
35         einfo "Updated virus definitions are not available for free."
36         einfo "You need a username and password to download them"
37         einfo "from http://acs.pandasoftware.com/software/basevirus/"
38 }
39
40 pkg_prerm() {
41         einfo "Removing stale logdir..."
42         [[ -d "${ROOT}/opt/pavcl/var/log/panda" ]] && rm -rf "${ROOT}/opt/pavcl/var/log/panda"
43 }