]> Pileus Git - ~andy/sunrise/blob - app-antivirus/clamtk/clamtk-4.42.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / app-antivirus / clamtk / clamtk-4.42.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils perl-module
8
9 DESCRIPTION="A frontend for ClamAV using Gtk2-perl"
10 HOMEPAGE="http://clamtk.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="Artistic GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 LANGS="ar ast bg bs ca cs da de el en_GB es eu fi fo fr gl he hr hu id it ja ko lt ms nb nl nn pl pt pt_BR ro ru sk sl sv te th tr ug uk uz zh_CN zh_TW"
18 IUSE="nls"
19 for i in ${LANGS}; do
20         IUSE="${IUSE} linguas_${i}"
21 done
22
23 DEPEND=""
24 RDEPEND=">=dev-perl/gtk2-perl-1.140
25         dev-perl/File-Find-Rule
26         dev-perl/libwww-perl
27         dev-perl/Date-Calc
28         dev-util/desktop-file-utils
29         >=app-antivirus/clamav-0.95
30         nls? ( dev-perl/Locale-gettext )
31         virtual/udev"
32
33 src_unpack() {
34         unpack ${A}
35         cd "${S}"
36         gunzip ${PN}.1.gz || die "gunzip failed"
37 }
38
39 src_install() {
40         dobin ${PN} || die "dobin failed"
41
42         doicon images/${PN}.png || die "doicon failed"
43         domenu ${PN}.desktop || die "domenu failed"
44
45         dodoc CHANGES README || die "dodoc failed"
46         doman ${PN}.1 || die "doman failed"
47
48         # The custom Perl modules
49         perlinfo
50         insinto ${VENDOR_LIB}/ClamTk
51         doins lib/*.pm || die "doins failed"
52
53         if use nls ; then
54                 domo po/*.mo || die "domo failed"
55         fi
56 }