]> Pileus Git - ~andy/sunrise/blob - app-admin/vlogger/vlogger-1.3.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / app-admin / vlogger / vlogger-1.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Virtual web logfile rotater/parser, similar to cronolog and httplog"
6 HOMEPAGE="http://n0rp.chemlab.org/vlogger/"
7 SRC_URI="http://n0rp.chemlab.org/${PN}/${P}.tar.gz"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="dbi"
13
14 DEPEND=""
15 RDEPEND="dev-perl/TimeDate
16         dbi? ( dev-perl/DBI )"
17
18 src_unpack() {
19         unpack ${A}
20         cd "${S}"
21         sed -e 's:/usr/local/sbin/vlogger:/usr/sbin/vlogger:' -i vlogger vlogger.1
22 }
23
24 src_install() {
25         doman vlogger.1
26         dodoc README
27         insinto /etc/vlogger
28         dosbin vlogger
29         if use dbi ; then
30                 doins vlogger-dbi.conf
31                 dodoc mysql_create.sql
32         fi
33 }
34
35 pkg_postinst() {
36         if use dbi ; then
37                 elog "If you wish to use vlogger with DBI please see /etc/vlogger/vlogger-dbi.conf"
38                 elog "The SQL to create the tables for DBI can be found in /usr/share/doc/${P}"
39         fi
40 }