]> Pileus Git - ~andy/sunrise/blob - app-admin/spass/spass-1.0.ebuild
app-admin/spass: New Ebuild for bug #199425
[~andy/sunrise] / app-admin / spass / spass-1.0.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="A secure password generator utility that utilizes /dev/random"
8 HOMEPAGE="http://www.guyrutenberg.com/category/projects/spass/"
9 SRC_URI="http://www.guyrutenberg.com/wp-content/uploads/2007/10/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND=""
18
19 S="${WORKDIR}/${PN}"
20
21 src_compile() {
22         emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" || die "emake failed"
23 }
24
25 src_install() {
26         dodir /usr/bin
27         emake DESTDIR="${D}" install || die "install failed"
28 }