]> Pileus Git - ~andy/sunrise/blob - app-admin/pwsafe/pwsafe-0.2.0.ebuild
app-admin/pwsafe: Use bindnow-flags properly
[~andy/sunrise] / app-admin / pwsafe / pwsafe-0.2.0.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils flag-o-matic
6
7 DESCRIPTION="Commandline program that manages encrypted password databases (compatible with Counterpane's Password Safe)"
8 HOMEPAGE="http://nsd.dyndns.org/pwsafe/"
9 SRC_URI="http://nsd.dyndns.org/pwsafe/releases/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND=""
18
19 src_compile() {
20         append-ldflags $(bindnow-flags)
21         econf || die "econf failed"
22         emake || die "emake failed"
23 }
24
25 src_install() {
26         emake DESTDIR="${D}" install || die "emake install failed"
27         dodoc README ChangeLog AUTHORS TODO NEWS
28         fperms +s /usr/bin/pwsafe
29 }
30
31 pkg_postinst() {
32         einfo "For the secure memory allocation to work, pwsafe has been installed"
33         einfo "as suid root."
34 }