]> Pileus Git - ~andy/sunrise/blob - app-admin/istatd/istatd-0.5.7.ebuild
app-misc/qbrew: Fix qt deps, EAPI bump
[~andy/sunrise] / app-admin / istatd / istatd-0.5.7.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6 inherit user
7
8 DESCRIPTION="Monitoring daemon serving statistics to your iStat iPhone application"
9 HOMEPAGE="http://bjango.com/apps/istat/"
10 SRC_URI="http://github.com/downloads/tiwilliam/${PN}/${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="qnaptemp"
16
17 DEPEND="dev-libs/libxml2"
18 RDEPEND="${DEPEND}"
19
20 pkg_setup() {
21         enewgroup istatd
22         enewuser istatd -1 -1 -1 "istatd"
23 }
24
25 src_configure() {
26         econf $(use_with qnaptemp)
27 }
28
29 src_install() {
30         emake DESTDIR="${D}" install || die "Install failed"
31
32         dodir /var/{run,cache}/${PN} || die
33         fowners istatd:istatd /var/{run,cache}/${PN} || die
34
35         newinitd "${FILESDIR}/istatd-init" ${PN} || die
36         newconfd "${FILESDIR}/istatd-conf" ${PN} || die
37
38         dodoc AUTHORS.txt DEVELOPERS.txt CHANGELOG.txt README.txt || die
39 }