]> Pileus Git - ~andy/sunrise/blob - app-admin/cpu-g/cpu-g-0.9.0.ebuild
x11-plugins/pidgin-sendscreenshot: Properly fix qt deps
[~andy/sunrise] / app-admin / cpu-g / cpu-g-0.9.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6 PYTHON_DEPEND="2"
7 inherit eutils python
8
9 DESCRIPTION="Displays information about your CPU, RAM, Motherboard and more"
10 HOMEPAGE="http://cpug.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN/-/}/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="
19         dev-python/pygobject:2
20         dev-python/pygtk:2"
21
22 src_prepare() {
23         sed -i -e "s:data/logos/:${EPREFIX}/usr/share/${PN}/data/logos/:" \
24                 -e "s:${PN}.glade:${EPREFIX}/usr/share/${PN}/${PN}.glade:" \
25                 ${PN} || die
26         python_convert_shebangs 2 ${PN}
27 }
28
29 src_install() {
30         dobin ${PN}
31         domenu data/${PN}.desktop
32         doicon data/${PN}.png
33         doman doc/${PN}.1
34         insinto /usr/share/${PN}
35         doins ${PN}.glade
36         rm data/${PN}.desktop || die
37         doins -r data
38 }