]> Pileus Git - ~andy/sunrise/blob - app-accessibility/onboard/onboard-0.94.0.ebuild
dev-libs/qextserialport: Fix qt deps, EAPI bump
[~andy/sunrise] / app-accessibility / onboard / onboard-0.94.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 PYTHON_DEPEND=2
8 SUPPORT_PYTHON_ABIS=1
9 RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
10
11 inherit gnome2-utils distutils versionator
12
13 DESCRIPTION="Simple on-screen Keyboard with macros and easy layout creation"
14 HOMEPAGE="https://launchpad.net/onboard"
15 SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
21
22 DEPEND="dev-python/python-distutils-extra"
23 RDEPEND="dev-python/gconf-python
24         dev-python/pyxml
25         dev-python/python-virtkey
26         x11-libs/cairo[svg]"
27
28 PYTHON_MODNAME="Onboard"
29
30 pkg_preinst() {
31         gnome2_icon_savelist
32 }
33
34 pkg_postinst() {
35         distutils_pkg_postinst
36         gnome2_icon_cache_update
37 }
38
39 pkg_postrm() {
40         distutils_pkg_postrm
41         gnome2_icon_cache_update
42 }